~Toughbooktalk~ Rob - 630-300-8877

The largest Toughbook discussion site on the net!
It is currently Fri May 25, 2018 2:12 pm

All times are UTC-06:00




Post new topic  Reply to topic  [ 18 posts ]  Go to page 1 2 Next
Author Message
PostPosted: Thu Sep 13, 2012 6:40 pm 
Offline

Joined: Tue Sep 11, 2012 4:27 pm
Posts: 28
Hello all,

Just bought my first Toughbook (in Australia)

Took a bit of a chance, it's a CF-18 came with nothing except the machine and a blue tab batterry, , no power supply, no hard drive or caddy, no disks, but it is in VERY good physical condition and it was cheap ($100)!
(I got a receipt and a record of the guys driving license).

The model is CF-18DHA37KA

I'm getting a power supply ready (it's a universal with the correct voltage output).

I want to take it slowly while I try to breathe life into it, so I'm not ordering Ram, Caddy (got a 60gb IDE drive) and disks until I know that it's not a doorstop.

I've done a bit of searching on the interweb, but I can't decode the model number.

I think it's got:

CMDA modem (The associated buttons are on the LHS)

GPS (it has the enlarged cover)

Touchscreen (it has a serial port)

512 ram (there's a 256 card under the speaker (the cover for which was a bit dented, that's why I took it off)

Can anyone give me a full breakdown of the spec based on the model number please.

I haven't even been able to power it up yet to get it to post, (will it post without a hard drive installed??).


Top
   
PostPosted: Thu Sep 13, 2012 7:58 pm 
Offline
User avatar

Joined: Wed Oct 07, 2009 9:19 pm
Posts: 1503
Location: FL
Welcome!

It will boot without a hard drive, press F2 to see the BIOS screens. The "37" means it's a customized private configuration. Sometimes these have BIOS problems e.g wifi locked out, but hopefully yours will not.

_________________
ToughBooks: CF-74 73 53 52 51 31 30 29 28 27 25 19 18 08 07 C1 C2 F9 H1 M32 M33 M34 R2 S10 T8 T5 T4 T2 U1 W2 Y2 VDW07 PDRC ...
GoBooks: VR-2, XR-1, IX-260+, IX-350


Top
   
PostPosted: Thu Sep 13, 2012 8:11 pm 
Offline

Joined: Tue Sep 11, 2012 4:27 pm
Posts: 28
OK, got a working power supply.

Upon plugging it in the Orange battery light comes on (it's just gone green).

Switching the power switch the green power light comes on, and the LCD brightless icon lights up, but nothing else happens, no display, I've tried increasing the Brightness but no response.

I don't have access to an external display here, I'll try that later.

Any ideas?? (maybe it's a doorstop!!)


Top
   
PostPosted: Thu Sep 13, 2012 9:40 pm 
Offline
User avatar

Joined: Tue Dec 21, 2010 12:51 pm
Posts: 1878
Location: Northeast Louisiana
The orange light means it's charging, swapping to green is normal. Sounds like you still have a good battery.

Two things to try. One shine a light on the screen to see if anything is on the screen. May be a bad backlight if you see anything on the screen.

Two, if nothing is on the screen, it gives no beeps. Flip the unit over and pull the bottom to give a look on the inside. I have got three CF-18's that were non-booting working by pulling the motherboard completely out, including unhooking the bios battery and waiting a few minutes and reinstalling them. Just make sure everything is reseated good and you don't loose/tear the thermal pads.

viewtopic.php?f=5&t=1146

There is our CF-18 guide.

Now even if it turns out dead don't give up hope. I have seen them popping up for sale alot but stripped out. Off of your doors, screen sides and keyboard will work on all CF-18's and some CF-19's. So you may find one later on that has been stripped and needs those parts.

I don't seem to have the country A the last number of your model number listed. Do you know any history of where the unit came from? Perhaps A = Australia, could be another one we could add to the list. As far as the 37 code goes some of that is explained in the guide. Are there any sticker on the unit that denote it came from a company?

_________________
CF-28 MK2,Mk3 / CF-29 Mk3 / CF-30 MK2 / CF-25 Mk1 ATI / CF-19 MK3/Mk3/Mk5 / CF-U1 Mk1,Mk2 / CF-M34 Mk7/Mk3 / CF-17 Mk1 / CF-07
Voodoo Envy M355 / M360 / M515 / M780 / U703 / Voodoo Hexx / Voodoo Idol / Voodoo Rage F1 / Voodoo Rage F1 / Voodoo Rage F1 "signed case" / Voodoo Omen
Alienware M11x R1


Top
   
PostPosted: Thu Sep 13, 2012 10:21 pm 
Offline

Joined: Tue Sep 11, 2012 4:27 pm
Posts: 28
Thanks for the quick reply guys, nice to know that there are knowledgeable helpful people still around!!!

Had a look in a fairly well lit room, angled the screen etc, I can't see any image at all on the screen, so it doesn't look like a backlight issue (unfortunately, I'll try an external monitor tonight, in case it's a display fault)

I'll try re-seating the motherboard and pulling the bios battery as suggested.

I think that the unit may be ex Telstra (Australian Phone company, they're big enough to be able to generate a special order/config code) from digging on the net, there were a couple of places on the unit where stickers had been removed, but there is nothing left to identify it.

I did find the exact model number listed on a Panasonic 'Supplementary Instructions for CDMA' doc but it only refers to the modem and the headset (I have a separate headset jack)

I contacted Panasonics' Toughbook representative in Australia with the serial number by email, we'll see if they can shed some light on what I have.


Top
   
PostPosted: Thu Sep 13, 2012 10:42 pm 
Offline
User avatar

Joined: Wed Oct 07, 2009 9:19 pm
Posts: 1503
Location: FL
A bad memory stick will keep it from booting up.

_________________
ToughBooks: CF-74 73 53 52 51 31 30 29 28 27 25 19 18 08 07 C1 C2 F9 H1 M32 M33 M34 R2 S10 T8 T5 T4 T2 U1 W2 Y2 VDW07 PDRC ...
GoBooks: VR-2, XR-1, IX-260+, IX-350


Top
   
PostPosted: Thu Sep 13, 2012 11:08 pm 
Offline

Joined: Tue Sep 11, 2012 4:27 pm
Posts: 28
Thanks, I'll try that too.

Am I missing a cover from underneath, everything seems to be so well sealed yet I have 4 open holes underneath near the port replicator port.


Attachments:
File comment: Pic of mystery holes
2012-09-13 08.00.55.jpg
2012-09-13 08.00.55.jpg [ 19.54 KiB | Viewed 3567 times ]
Top
   
PostPosted: Fri Sep 14, 2012 12:51 am 
Offline
User avatar

Joined: Tue Dec 21, 2010 12:51 pm
Posts: 1878
Location: Northeast Louisiana
Image

It's not just you, everyone with a 18 has that, lol. The rubber seal for the bottom goes around that so it still seals the motherboard off.

I have seen a few but never got my hands on on WWAN model with voice. All CF-18's have the place for it covered with a sticker as most of the WWAN daughter boards are not set up to plug in with voice directly.

Check your basics and un-plug the ram, wireless cards, battery, etc. To make sure they aren't causing a problem.

If you have a good flash light try the boot up and light again. Sometime you just can't see it. But if the screen is lighting up and just blank you aren't getting a signal to the screen.

_________________
CF-28 MK2,Mk3 / CF-29 Mk3 / CF-30 MK2 / CF-25 Mk1 ATI / CF-19 MK3/Mk3/Mk5 / CF-U1 Mk1,Mk2 / CF-M34 Mk7/Mk3 / CF-17 Mk1 / CF-07
Voodoo Envy M355 / M360 / M515 / M780 / U703 / Voodoo Hexx / Voodoo Idol / Voodoo Rage F1 / Voodoo Rage F1 / Voodoo Rage F1 "signed case" / Voodoo Omen
Alienware M11x R1


Top
   
PostPosted: Fri Sep 14, 2012 6:23 am 
Offline

Joined: Tue Sep 11, 2012 4:27 pm
Posts: 28
It was a bad ram stick, thanks guys!!! Ram out, booted straight away :pbjt:

Now I can't get into the bios because a password is set, (I did ask the clown who I bought it off the specific question whether there was one set, he said no)

Still it's an easy fix and I know that it's not dead.

I'll get myself an SSD then the fun begins installing the drivers (unless I can get a restore disk shipped to Australia).

Thanks again, I'm feeling pretty pleased about the progress


Top
   
PostPosted: Fri Sep 14, 2012 6:49 am 
Offline
Toughbooktalk Moderator
User avatar

Joined: Sat Mar 28, 2009 7:59 pm
Posts: 2614
Location: "TOUGHBOOK LAND" ME ,USA / NB . CANADA
You should feel good...$100.00 for a CF-18 in Australia. You stole it :D

_________________
:spinny: Blair :spinny:
___________________
CF-19 MK1 /2 Emissive Keyboard * CF-28 MK3
CF-30 MK2 , Intel SSD, 4GB , GPS, W7 Ultimate , Bluetooth, Emissive Keyboard
CF-51 MK3LL Core 2 Duo T7600 Mod , W7, 4GB Ram, 160GB 7200RPM HDD, Finger Print Reader
CF-52MK1 Core2Duo 2GHz, Intel SSD X25 Series ,4GB , BT with dock
CF-52 MK4 i5‑2540M 2.60GHz, ATI Discrete Graphics, Intel 120GB SSD, 16GB,W7 Pro 64bit
CF-53MK1 i5/2520, Kingston Hyper X SSD 240GB, 16GB memory, W7 Pro 64bit with dock
And the little guys CF-M34 MK3 and MK7
Infologix / MediSlate 10.4" tablet
Cel Google Pixel XL
Member of:
http://thessdreview.com/
http://www.toughbooktalk.com
http://forum.notebookreview.com/panasonic/


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 18 posts ]  Go to page 1 2 Next

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited